Regulacja obrotami silnika

Jak nie podepniesz to nie zaiskrzy.
Awatar użytkownika
mateusz45412
Witaj. Zanim zapytasz - poszukaj i poczytaj!
Posty: 3
Rejestracja: 10-08-2017
Lokalizacja: Rzeszów
Podziękował: 1 raz

Postautor: mateusz45412 » 11 sie 2017, o 17:21

Witam
Posiadam problem z regulacją obrotami silnika. Mianowicie po podłączeniu silnika z regulatorem i odbiornikiem nie uzyskuje regulacji od zera do max, tylko od 2,07 [v] do 4,17 [v].
Korzystam z następujących części:

- Sterownik silników DC - TB6612FNG
- Odbiornik FlySky FS-iA10B 10CH
- Silnik DC 3,7-4,2V https://abc-rc.pl/silniki-mini-dron-716-smigla
- Aparartura FlySky FS-i6X ( niedawno kupiłem i jeszcze wszystkiego nie wiem )
- AKUMULATOR LIPO 1000 mah 3s 11,1V 20C JST
http://allegro.pl/bateria-akumulator-li ... ule_id=201
5v zasilam ze starej ładowarki do telefonu
Wszystko połączone jest na płytce stykowej, schemat tak jak na zdjęciu.
Akumulator co prawda ma 11,1 [v] ale w ustawieniach odbiornika RX SETUP -> SERVOS FREQ ustawiłem 185. Posiadając takie ustawienia wpiąłem woltomierz zamiast silnika i otrzymałem regulacje od 2,07 [v] do 4,17 [v]. Gdy ten parametr zwiększę napięcie też się zwiększa. A poza tym silnik pracujący na min czyli 2,07 [v] pracuje dobrze tylko się grzeje, ale gdy jest na maksymalnych obrotach to chwilę jest dobrze a potem go dusi . Jak rozwiązać te problemy to nie wiem .
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.
Awatar użytkownika
mwx
Elita forum...
Posty: 924
Rejestracja: 23-09-2016
Lokalizacja: Poznań West
Podziękował: 4 razy
Podziękowano: 85 razy

Postautor: mwx » 11 sie 2017, o 22:54

Wszystko działa zgodnie z instrukcją, której pewno nie przeczytałeś zbyt dokładnie.

Ten regulator steruje się poziomem wypełnienia sygnału PWM (0-100%), a nie długością trwania impulsu jak w serwach czy modelarskich regulatorach obrotów (0.7-2.3ms)

Żeby nim sterować zmajstruj sobie w celach dydaktycznych generator sygnału PWM na timerku ne555. Pełno w sieci schematów, a komponenty kosztują grosiki. Albo lepiej podłącz to to arduino, choć nie wiem czy ogarniasz ten temat.

Sygnał PWM sterujący serwem, z którego próbujesz korzystać nigdy nie osiągnie poziomu wypełnienia zbliżonego do 100%, maksymalnie raczej coś w okolicach 30% (zakładając że odbiornik pracuje w trybie High Speed, czyli z odświeżaniem co 7ms a sygnał dla serwa ma ok 2ms)

Generalnie połączyłeś ze sobą 2 elementy nie przeznaczone do współpracy i dzięki odrobinie szczęscia udało Ci się osiągnąć JAKIEŚ tam sterowanie i niczego nie popalić. Zgłęb tajniki sterowania serwami modelarskimi (jest opracowanie na tym forum) i podstawy sterowania poziomem wypełnienia (PWM) a pojmiesz że to niestety w tej konfiguracji działać nie będzie.
Maciej
Latające muzeum: 600NSP Brain2, FrankenBelt CPX FBL, HS Emax X-450
Debil 380
T8FG, 9CAP
krety na JuTubach
Awatar użytkownika
mateusz45412
Witaj. Zanim zapytasz - poszukaj i poczytaj!
Posty: 3
Rejestracja: 10-08-2017
Lokalizacja: Rzeszów
Podziękował: 1 raz

Postautor: mateusz45412 » 15 sie 2017, o 20:17

Rzeczywiście masz racje, nie dostrzegłem tej różnicy. W takim razie wydaje mi się, że lepiej będzie kupić silnik bezszczotkowy + ESC i wtedy powinno wszystko działać.
Awatar użytkownika
miruuu
Administrator
Posty: 13434
Rejestracja: 11-05-2010
Lokalizacja: Warszawa - Ursynów
Podziękował: 1340 razy
Podziękowano: 597 razy
Kontaktowanie:

Postautor: miruuu » 16 sie 2017, o 05:25

Mateusz, uzupełnisz awatar i lokalizacje? Taki mamy tutaj fetysz ;)
Pozdrawiam, Mirek

Trex 470LM - cieszy... | Trex 500X - przyszedł... | Reaktor 3D - jest co bić | Firstar - mały ale wariat ;) | Szybolek - zrobiony, oblatany, do sprzedania... | Czesia - jeszcze tylko wyniosę choinkę i się za nią biorę... | LaTrax Rally - kazali mi kupić | Graupner MX-20 - działa

Wróć do „Silniki elektryczne i akcesoria”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość